PG Software - Votre distributeur IT

Editeur : ManageEngine
Produit : OpManager
Date de la release : 22/04/22

N° de version 125604 - 22 avril 2022

Général :

  • Le processus de mise à niveau a échoué dans la configuration de reprise sur panne en raison d'un problème. Ce problème se produit lors de la mise à niveau à partir de builds inférieurs à 125561. Ce problème a été corrigé.
  • Lors de la mise à niveau vers une version 12.5.399 et supérieure, la migration des rôles d'utilisateur échouait en raison d'entrées de propriétés d'utilisateur manquantes dans la base de données. Ce problème a maintenant été corrigé.
  • La prise en charge de l'authentification basée sur SAML 2.0 est désormais assurée. Les utilisateurs peuvent maintenant se connecter via le service SAML Single Sign-On une fois que les détails du fournisseur d'identité (IdP) sont configurés.
  • Les paramètres de configuration de l'authentification sont désormais regroupés dans une nouvelle section intitulée "Authentification" sous Paramètres généraux.
  • L'interface de la page de connexion est maintenant optimisée pour une meilleure expérience utilisateur.
  • L'authentification directe est en cours de dépréciation et sera supprimée dans l'une des prochaines versions avant 2023. Les utilisateurs qui ont déjà configuré l'authentification directe n'auront pas d'impact pour le moment et les nouveaux utilisateurs ne seront pas autorisés à la configurer.

OpManager :

  • Les problèmes de vulnérabilité à l'injection SQL, identifiés dans quelques rapports par défaut ont été corrigés (rapporté par Anh Vu).
  • Les problèmes de vulnérabilité d'injection SQL dans plusieurs rapports d'inventaire ont été corrigés. (Signalé par Anh Vu. Référence : CVE-2022-27908).
  • Les graphiques d'interface affichaient les données du tableau brut au lieu du tableau horaire dans le rapport planifié ou le PDF exporté. Ce problème a maintenant été corrigé.Introduction d'un nouveau moniteur VMware que les clients peuvent utiliser pour surveiller l'espace disque de leurs machines virtuelles VMware, à condition que les outils VMware nécessaires soient installés dans la machine virtuelle.
  • Lorsque le traitement des données était effectué pour vmwareevents.xml pendant la mise à niveau de la configuration de l'entreprise, la mise à niveau échouait si des modifications étaient apportées aux événements VMWare par défaut dans la configuration pré-mise à niveau. Ce problème a été corrigé.
  • Les problèmes de vulnérabilité XSS dans les noms de fichiers mib, les pages Add WMI sous les pages de paramètres et de modèles de dispositifs, et la colonne "Device Count" sous Settings -> Monitoring -> Pages ont été corrigés.
  • : L'API 'getVPNTunnelDetails' a été supprimée. Comme alternative, vous pouvez utiliser l'API 'getVPNDetails' pour récupérer les détails du VPN.
  • L'API 'GMapDetails' a été supprimée. En remplacement, vous pouvez utiliser l'API "getMapProperties" pour obtenir les propriétés des cartes.
  • Auparavant, les utilisateurs ne pouvaient pas ajouter des moniteurs IP SLA lorsque la taille de la valeur 'Application version' dépassait la limite de 50 caractères. Ce problème a été corrigé.
  • L'interrogation de la collecte de données des dispositifs Switch Stack a été optimisée pour éviter une utilisation élevée de la mémoire.
  • Auparavant, l'état de gravité d'arrêt pour les dispositifs UPS n'était pas effacé même lorsque le dispositif était de nouveau en marche. Ce problème a été corrigé.
  • Network Path Analysis est désormais pris en charge dans l'édition Enterprise de OpManager pour les installations Windows.
  • Auparavant, les utilisateurs 'opérateur' ne pouvaient pas mettre à jour la colonne 'Reason' sous l'historique des pannes dans la page Device Snapshot. Ce problème a été résolu.
  • Auparavant, le seuil pour le moniteur 'VPN Tunnel Status' n'était pas configuré par défaut si le moniteur était associé manuellement (en utilisant l'option 'Add monitor' ou 'Associate') depuis la page Performance Monitors. Ce problème a été corrigé.
  • Auparavant, les widgets VPN étaient incorrectement affichés dans la page de l'instantané pour les dispositifs qui ne prennent pas en charge la surveillance VPN site à site. Ce problème est maintenant résolu.
  • Auparavant, les paramètres de seuil n'étaient pas désactivés pour les moniteurs d'état des tunnels VPN. Ce problème a désormais été corrigé.
  • Auparavant, le texte Start/Stop dans la colonne 'Action' du widget Access Points du WLC était recouvert de caractères déformés. Ce problème a été résolu.
  • Les problèmes de vulnérabilité XSS dans la page des modèles de fournisseurs ont été corrigés.
  • Auparavant, des caractères déformés étaient affichés avec les valeurs de seuil des moniteurs d'utilisation, d'erreur et de rejet dans la page 'Applying Interface Template'. Ce problème a été corrigé.
  • Dans la page de l'instantané du dispositif, le message d'aide ne s'affichait pas pour les dispositifs avec un type de dispositif 'Inconnu' ou lorsque le dispositif était ajouté dans OpManager dans l'état 'Non surveillé'. Ce problème a été corrigé.
  • Auparavant, les utilisateurs n'ayant qu'un accès en écriture de découverte ne pouvaient pas ajouter des dispositifs à partir de la page "Ajouter un dispositif" ou accéder à la page d'instantané des dispositifs de routeur. Ce problème a été corrigé maintenant.

NCM :

  • La prise en charge de la gestion de la configuration basée sur l'API REST a été ajoutée pour les dispositifs HPE Aruba OS.
  • Les utilisateurs peuvent maintenant configurer le statut de détection de changement de syslog à partir de l'interface utilisateur.
  • Auparavant, il y avait un problème lors du chargement de la page des paramètres dans MSP Central lorsqu'un utilisateur de rôle est créé avec l'add-on NCM. Il a été corrigé maintenant.